The longitude of the site location.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The longitude, in radians between -PI and PI. If the value is not between -PI and PI, it will be shifted by multiples of 2PI until it is in range.Remarks
A property that contains the longitude of the site location. The value of this property is in radians between +PI and -PI. If the given value is not between -PI and PI, it will be shifted by multiples of 2PI until it is in range.
When setting this property:
- Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
- Revit will attempt to automatically adjust the time zone value to match the new Longitude value set using [!:Autodesk::Revit::DB::SunAndShadowSettings::CalculateTimeZone] . For some boundary cases, the time zone calculated may not be correct. You can set the TimeZone property directly to the correct value if necessary.
- Revit will attempt to automatically update the weather station associated with the coordinates.