Builds a KeyBasedTreeEntries object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This method will take all the entries that have been added, create a KeyBasedTreeEntries object out of these entries, and also record possible errors that occurred while constructing this KeyBasedTreeEntries object. After this function is called, no more entries can be added. And repeated calling of this function is not allowed either.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported. |