Converts a user-visible path (string) to a ModelPath.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- strPath
-
Type:
System
String
The path in string form, like RSN://{HostNodeName}/school/project.rvt
Return Value
A ModelPath representing either a server or file path.Remarks
The path may be a server or file path.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |