TreadThickness Property


The thickness of the treads.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public double TreadThickness { get; set; }
Visual Basic
Public Property TreadThickness As Double
	Get
	Set
Visual C++
public:
property double TreadThickness {
	double get ();
	void set (double value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: The given value for thickness must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions InvalidOperationException When setting this property: The run type has no tread so the data being set is not applicable.

See Also