BasePoint Class


A class representing the Project Base Point and Survey Point. Each Revit project contains one project base point and one survey point. The project base point represents the origin of the project coordinate system. The survey point represents the origin of the shared coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)

Syntax

C#
public class BasePoint : Element
Visual Basic
Public Class BasePoint _
	Inherits Element
Visual C++
public ref class BasePoint : public Element

Inheritance Hierarchy

See Also