GetFluidType Method


Gets a fluid type by name.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public static FluidType GetFluidType(
	Document document,
	string fluidTypeName
)
Visual Basic
Public Shared Function GetFluidType ( _
	document As Document, _
	fluidTypeName As String _
) As FluidType
Visual C++
public:
static FluidType^ GetFluidType(
	Document^ document, 
	String^ fluidTypeName
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document.
fluidTypeName
Type: System String
The name of fluid type.

Return Value

The fluid type. a null reference ( Nothing in Visual Basic) if the fluid type was not found.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also