TagTypeId Property


The tag type which will be used by the child tag the multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public ElementId TagTypeId { get; set; }
Visual Basic
Public Property TagTypeId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ TagTypeId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Field Value

The tag type must be able to tag elements belonging to the multi-reference annotation's reference category.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The tag type is not allowed.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also