DimensionStyleId Property


The dimension style which will be used by the child dimension of the multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public ElementId DimensionStyleId { get; set; }
Visual Basic
Public Property DimensionStyleId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ DimensionStyleId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Field Value

Only linear dimension styles can be used.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The dimension style is not allowed.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also