GetPumpSets Method


Gets the set of element Id's for all pump sets in the system, if any.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2019

Syntax

C#
public ISet<ElementId> GetPumpSets()
Visual Basic
Public Function GetPumpSets As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetPumpSets()

Return Value

The set of all the pump sets in the system.

See Also