GetAllStructuralConnectionTypeIds Method


Collects the ids of all StructuralConnectionTypes in the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public static void GetAllStructuralConnectionTypeIds(
	Document cda,
	out ICollection<ElementId> ids
)
Visual Basic
Public Shared Sub GetAllStructuralConnectionTypeIds ( _
	cda As Document, _
	<OutAttribute> ByRef ids As ICollection(Of ElementId) _
)
Visual C++
public:
static void GetAllStructuralConnectionTypeIds(
	Document^ cda, 
	[OutAttribute] ICollection<ElementId^>^% ids
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also