DisabledDisciplineException Class


The exception that is thrown when the function cannot execute because a discipline is disabled. The exception specifies which discipline(s) would let the operation succeed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
[SerializableAttribute]
public class DisabledDisciplineException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class DisabledDisciplineException _
	Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class DisabledDisciplineException : public InvalidOperationException

Inheritance Hierarchy

See Also