A Rebar Hook type object that is used in the generation of Rebar.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This object contains the definition of the hooks that may be created at the ends
of the rebar. The specifics of these hooks are angle (range 0-PI) between first/last
segment of rebar and the straight segment of the hook, rebar shape style and
a multiplier used to compute the length of the straight segment of the hook.
The default length is computed as the bar diameter * the multiplier.
Length can be overridden by settings in the RebarBarType class.
Inheritance Hierarchy
System
Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB ElementType
Autodesk.Revit.DB.Structure RebarHookType
Autodesk.Revit.DB Element
Autodesk.Revit.DB ElementType
Autodesk.Revit.DB.Structure RebarHookType