RevolvedFace Class


A revolved face of a 3d solid or open shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)

Syntax

C#
public class RevolvedFace : Face
Visual Basic
Public Class RevolvedFace _
	Inherits Face
Visual C++
public ref class RevolvedFace : public Face

Remarks

Revolved faces are defined by a profile curve and a local coordinate system. For details on the parameterization, refer to the documentation for RevolvedSurface

Examples

Copy C#
private void GetRevolvedFaceInfo(Face face)
{
    RevolvedFace revolvedFace = face as RevolvedFace;
    if (null != revolvedFace)
    {
       XYZ origin = revolvedFace.Origin;
       XYZ axis = revolvedFace.Axis;
        Curve curve = revolvedFace.Curve;
        XYZ redius = revolvedFace.get_Radius(0);
    }
}
Copy VB.NET
Private Sub GetRevolvedFaceInfo(face As Face)
    Dim revolvedFace As RevolvedFace = TryCast(face, RevolvedFace)
    If revolvedFace IsNot Nothing Then
        Dim origin As XYZ = revolvedFace.Origin
        Dim axis As XYZ = revolvedFace.Axis
        Dim curve As Curve = revolvedFace.Curve
        Dim redius As XYZ = revolvedFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

See Also