IsAllowedReferenceCategory Method


Checks if the reference category can be used with multi-reference annotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public bool IsAllowedReferenceCategory(
	ElementId referenceCategoryId
)
Visual Basic
Public Function IsAllowedReferenceCategory ( _
	referenceCategoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsAllowedReferenceCategory(
	ElementId^ referenceCategoryId
)

Parameters

referenceCategoryId
Type: Autodesk.Revit.DB ElementId
The reference category to check.

Return Value

True when the reference category can be used by multi-reference annotations.

Remarks

Only Structural Rebar is allowed.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also