Encapsulates basic information about a Revit file, including worksharing status, Revit version, username and central path.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This class provides a fast access to get basic information without fully opening a Revit file. The
Extract
method
can initialize a new instance of this class by providing a full path for Revit file, including project (.rvt) and family (.rfa) files.
This class can extract information from files of older formats.
If the structure of the BasicFileInfo storage has not changed,
it can also extract information from files of newer formats
(making the method
IsSavedInLaterVersion
relevant).
However, if the structure of the storage has changed in a newer file format,
Extract
will not be able to extract the information.