PathOfTravelCalculationRequestType Enumeration


An enumerated type containing possible requests for the Path of Travel calculation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.1.1.1)
Since: 2020
Since: 2020

Syntax

C#
public enum PathOfTravelCalculationRequestType
Visual Basic
Public Enumeration PathOfTravelCalculationRequestType
Visual C++
public enum class PathOfTravelCalculationRequestType

Members

Member name Description
CalculateForCorrespondingStartEndPairs Calculate paths of travel between corresponding pairs of start and end points.
CalculateForAllPossibleStartEndPairs Calculate paths of travel between all possible pairs of start and end points.
CalculatePathOfTravelObstaclesInView Calculate only path of travel obstacles in the view.
GetRevealObstaclesModeInView Determine if reveal obstacles mode is on or off in the view.
SetRevealObstaclesModeInView Sets reveal obstacles mode in the view.
LockCache Lock changes to internal caches
UnlockCache Allow changes to internal caches

See Also