StartTangent Property


Gets or sets the tangent vector at the start of the curve. The invalid or zero vector is ignored when setting the tangent.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public XYZ StartTangent { get; set; }
Visual Basic
Public Property StartTangent As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ StartTangent {
	XYZ^ get ();
	void set (XYZ^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also