NewInstanceBinding Method (CategorySet)


Creates a new instance binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public InstanceBinding NewInstanceBinding(
	CategorySet categorySet
)
Visual Basic
Public Function NewInstanceBinding ( _
	categorySet As CategorySet _
) As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding(
	CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit.DB CategorySet
A set of categories that will be added to the binding.

Return Value

A new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category.

See Also