GetHookTangentLength Method


Identifies the hook tangent length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public double GetHookTangentLength(
	ElementId hookId
)
Visual Basic
Public Function GetHookTangentLength ( _
	hookId As ElementId _
) As Double
Visual C++
public:
double GetHookTangentLength(
	ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB ElementId
id of the hook type

Return Value

The hook tangent length for a hook type

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also