ImageTypeOptions Class


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2020

Syntax

C#
public class ImageTypeOptions : IDisposable
Visual Basic
Public Class ImageTypeOptions _
	Implements IDisposable
Visual C++
public ref class ImageTypeOptions : IDisposable

Remarks

ImageTypeOptions determines how an image file is accessed for the purposes of validation and creation of an ImageType. ImageTypeOptions can be set up to refer to a particular file using either a string path or an external resource reference.

When a file is accessed with the help of an external server, it is likely that the server will cache the file temporarily. ImageTypeOptions may refer to the cached copy of the file internally. For this reason, ImageTypeOptions should be treated as a transient object whose purpose is to become an argument to ImageType.Create(Document, ImageTypeOptions) or ImageType.ReloadFrom(ImageTypeOptions) . An application should not create an ImageTypeOptions object and hold onto it for a long time.

Inheritance Hierarchy

System Object
Autodesk.Revit.DB ImageTypeOptions

See Also