Determines whether the given string represents a valid
server path.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- strPath
-
Type:
System
String
The path, in string form
Return Value
True if the given path is a valid server path, false otherwise.Remarks
ServerPaths must refer to Revit models.
ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".
The {model_path} portion is a relative path to a Revit model. For example:
- RSN://EXS/hospital.rvt
- RSN://EXS.autodesk.com/Old Files/hotel2.rvt
- RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
- //EXS/Old Files/.rvt
- EXS/hospital
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |