Initializes a new instance of the
FamilyInstanceCreationData
class
Namespace:
Autodesk.Revit.Creation
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curve
-
Type:
Autodesk.Revit.DB
Curve
The curve where the instance is based.
- symbol
-
Type:
Autodesk.Revit.DB
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- level
-
Type:
Autodesk.Revit.DB
Level
A Level object that is used as the base level for the object.
- structuralType
-
Type:
Autodesk.Revit.DB.Structure
StructuralType
If structural then specify the type of the component.