A constraint that measures the length of a segment as measured by projecting onto a direction
that is not parallel to the segment.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
The constraint has two references, indexed by 0 and 1, that do not have to
correspond to the start and end of the segment. The constraint also specifies
a direction as a 2D vector, which is not necessarily parallel to the segment,
but must point from the segment's start toward its end.
Inheritance Hierarchy
System
Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintProjectedSegmentLength
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintProjectedSegmentLength