Space Class


Provides access to the space topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class Space : SpatialElement
Visual Basic
Public Class Space _
	Inherits SpatialElement
Visual C++
public ref class Space : public SpatialElement

Remarks

The space object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

See Also