Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This table is structured as a mapping from ExportFontKey to ExportFontInfo members. The ExportFontKey contains the indentification information for the font table: the Revit font name. The ExportFontInfo contains the font name to use in the export format.
The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportFontInfo returned will be a copy of the ExportFontInfo from the table. In order to make changes to the ExportFontInfo and use those settings during export, set the modified ExportFontInfo back into the table using the same key.