A type used to identify the particular part of a Stirrup style rebar to which
a Standard style rebar's handle is constrained.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2014
Since:
2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
RebarPlane | Handle is constrained to the location of the other Rebar's primary plane. Drives location of the entire Rebar along the direction of its normal. |
StartOfBar | Handle is constrained to start point of the other Rebar. |
EndOfBar | Handle is constrained to end point of the other Rebar. |
Edge | Handle is constrained to location of a single edge segment of the other Rebar. Drives the edge in the direction perpendicular to the edge and in the Rebar's primary plane. |
OutOfPlaneExtent | Handle is constrained to the extent of a three-dimensional Rebar out of its primary plane. This includes the length of a Rebar Set, the out-of-plane length of a multi-planar Rebar, and the length of a spiral Rebar. |
BarBend | Handle is constrained to fillet of the edge of the other Rebar. |
HookBend | Handle is constrained to fillet of the hook of the other Rebar. |
Remarks
Most of the range of values for this type are the same as those of RebarHandleType,
since it is usually the handles on the Stirrup which constrain the Standard bar.
However, two additional values - BarBend and HookBend - are used to identify the
special case of a Standard style, straight bar, running perpendicular to the plane
of the Stirrup, and constrained to a bend (or hook) arc on the Stirrup.