RebarShapeDefinition Class


A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2009

Syntax

C#
public class RebarShapeDefinition : IDisposable
Visual Basic
Public Class RebarShapeDefinition _
	Implements IDisposable
Visual C++
public ref class RebarShapeDefinition : IDisposable

Remarks

A RebarShapeDefinition stores a set of Rebar Shape parameters. Each parameter may be associated with:
  • One or more RebarShapeConstraints; or
  • A formula; or
  • Neither of the above.
Each shape instance (Rebar object) will have its own values for these parameters. The RebarShapeDefinition also stores a default value for each parameter, which is ignored if the parameter is associated with a formula.

Inheritance Hierarchy

See Also