Mesh Class


A triangular mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)

Syntax

C#
public class Mesh : GeometryObject
Visual Basic
Public Class Mesh _
	Inherits GeometryObject
Visual C++
public ref class Mesh : public GeometryObject

Remarks

Meshes are generated during triangulation of faces. They can also be encountered directly in Revit geometry (typically imported geometry). Meshes contain a single array of Vertices , and a corresponding array of triangles. Triangles can be accessed by index from Triangle Int32 , and reference 3 vertices from the Vertices array.

Inheritance Hierarchy

See Also