PointOnEdge Class


Define a ReferencePoint relative to a referenceable edge or curve on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class PointOnEdge : PointElementReference
Visual Basic
Public Class PointOnEdge _
	Inherits PointElementReference
Visual C++
public ref class PointOnEdge : public PointElementReference

Remarks

The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.

Inheritance Hierarchy

See Also