ServerPath Class


This class represents a path to a Revit Server location, rather than a location on disk or a network drive.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public class ServerPath : ModelPath
Visual Basic
Public Class ServerPath _
	Inherits ModelPath
Visual C++
public ref class ServerPath : public ModelPath

Remarks

ServerPaths must refer to Revit models.

ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".

The {model_path} portion is a relative path to a Revit model. For example, the following are valid server paths:

  • RSN://EXS/hospital.rvt
  • RSN://EXS.autodesk.com/Old Files/hotel2.rvt
  • RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
The following would not be valid server paths:
  • //EXS/Old Files/.rvt
  • EXS/hospital

Inheritance Hierarchy

See Also