ImageType Class


Represents a type containing a raster based image. ImageInstances of this type can be placed in 2D views, sheets, and schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2015

Syntax

C#
public class ImageType : ElementType
Visual Basic
Public Class ImageType _
	Inherits ElementType
Visual C++
public ref class ImageType : public ElementType

Remarks

ImageType elements are created with the ImageType.Create(Document, ImageTypeOptions) method.

ImageType elements can be loaded from the following file types: *.bmp, *.jpg, *.jpeg, *.png, *.tif.

In addition, when PDF support is available, ImageType elements can also be loaded from *.pdf files. See: IsPDFImportAvailable

Inheritance Hierarchy

See Also