SymbolicCurve Class


A curve that provides information but is not intended to represent actual geometry in an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class SymbolicCurve : CurveElement
Visual Basic
Public Class SymbolicCurve _
	Inherits CurveElement
Visual C++
public ref class SymbolicCurve : public CurveElement

Remarks

For example, when creating a door family, you might sketch symbolic lines in an elevation view to represent a door swing. Symbolic curves are visible parallel to the view in which you sketch them.

Inheritance Hierarchy

See Also