GetReportContent Method


Gets the report content for display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.1.1.1)
Since: 2020.1

Syntax

C#
public string GetReportContent()
Visual Basic
Public Function GetReportContent As String
Visual C++
public:
String^ GetReportContent()

Return Value

The content of the report as displayed in the view.

Remarks

The report shows "Calculating..." if the background calculation is still going on. You may call isAnalysisCompleted() to check if the calculation is completed.

See Also