GetAutoCalcHookLengths Method


Identifies if the hook lengths of a hook type are automatically calculated for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public bool GetAutoCalcHookLengths(
	ElementId hookId
)
Visual Basic
Public Function GetAutoCalcHookLengths ( _
	hookId As ElementId _
) As Boolean
Visual C++
public:
bool GetAutoCalcHookLengths(
	ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB ElementId
id of the hook type

Return Value

True if the hook lengths are automatically calculated, otherwise false

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also