SystemZoneData Class


Represents the specific domain requirements for a system-zone used in MEP design.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.1.1.1)
Since: 2020.1

Syntax

C#
public class SystemZoneData : GenericZoneDomainData
Visual Basic
Public Class SystemZoneData _
	Inherits GenericZoneDomainData
Visual C++
public ref class SystemZoneData : public GenericZoneDomainData

Remarks

A system-zone is used to specify what parts of a building are served by specific equipment, air systems and water loops without having to physically model them. A system-zone is represented as a GenericZone element with a domain data of type SystemZoneData, which contains specific domain requirements for the purpose of analysis.

Inheritance Hierarchy

See Also