HostFace Property


Property to get the reference to the host face of family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public Reference HostFace { get; }
Visual Basic
Public ReadOnly Property HostFace As Reference
	Get
Visual C++
public:
property Reference^ HostFace {
	Reference^ get ();
}

Field Value

If the instance is placed on a work plane, this property will return the reference to the geometry face underlying the work plane. If the work plane is not referencing other geometry, this property will return a null reference ( Nothing in Visual Basic) . If the instance is not hosted on a face or work plane, this property will return a null reference ( Nothing in Visual Basic) .

See Also