Namespace:
Autodesk.Revit.UI.Selection
Assembly:
RevitAPIUI
(in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- objectType
-
Type:
Autodesk.Revit.UI.Selection
ObjectType
Specifies the type of object to be selected.
Return Value
A reference object selected by user.
Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.
Remarks
Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.
The selection will not be automatically added to the active selection buffer.
Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.
Examples
Selection choices = uidoc.Selection;
// Pick one object from Revit.
Reference hasPickOne = choices.PickObject(ObjectType.Element);
if (hasPickOne != null)
{
TaskDialog.Show("Revit", "One element selected.");
}
Dim choices As Selection = uidoc.Selection
' Pick one object from Revit.
Dim hasPickOne As Reference = choices.PickObject(ObjectType.Element)
If hasPickOne IsNot Nothing Then
TaskDialog.Show("Revit", "One element selected.")
End If
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value. |
Autodesk.Revit.Exceptions OperationCanceledException | Thrown when the Revit user cancels this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode. |
Autodesk.Revit.Exceptions ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update. |