SetLayers Method


Completely resets this CompoundStructure and applies a new set of layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public void SetLayers(
	IList<CompoundStructureLayer> layers
)
Visual Basic
Public Sub SetLayers ( _
	layers As IList(Of CompoundStructureLayer) _
)
Visual C++
public:
void SetLayers(
	IList<CompoundStructureLayer^>^ layers
)

Parameters

layers
Type: System.Collections.Generic IList CompoundStructureLayer
The layers to be set.

Remarks

This function will replace all existing layers with the contents of the input. This provides a full reset for the CompoundStructure. Therefore:

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also