Returns an instance of BasicFileInfo filled with basic information about a Revit file located at the given file-path
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- file
-
Type:
System
String
The full path to the file to be queried, including project (.rvt) and family (.rfa) files.
Return Value
If successful, basic file data.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions FileArgumentNotFoundException | The file doesn't exist. |
Autodesk.Revit.Exceptions InvalidOperationException | The file is a newer format file where the structure of the BasicFileInfo storage has changed, or the file is saved in very old version of Revit without basic file data. |