SpatialElementTag Class


A tag attached to a SpatialElement (room, space or area) in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)

Syntax

C#
public class SpatialElementTag : Element
Visual Basic
Public Class SpatialElementTag _
	Inherits Element
Visual C++
public ref class SpatialElementTag : public Element

Remarks

SpatialElementTag is the base class for RoomTag, SpaceTag and AreaTag. Zone tag is not derived from SpatialElementTag. See [!:Autodesk::Revit::DB::IndependentTag] for more information.

Inheritance Hierarchy

See Also