GetSubPartIds Method


Gets ids of subpart elements. After connection regeneration ids may become invalid.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2017

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2020 and will be removed in the next version of Revit.")]
public IList<ElementId> GetSubPartIds()
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2020 and will be removed in the next version of Revit.")> _
Public Function GetSubPartIds As IList(Of ElementId)
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2020 and will be removed in the next version of Revit.")]
public:
IList<ElementId^>^ GetSubPartIds()

See Also