AlternatingBarShapeId Property


The RebarShape element that defines the shape of the alternating bars of the Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public ElementId AlternatingBarShapeId { get; set; }
Visual Basic
Public Property AlternatingBarShapeId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ AlternatingBarShapeId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

Changing the value of this property causes the Path Reinforcement to choose values for its shape parameters. Before calling this method, alternating bars have to be enabled in the Path Reinforcement by setting PATH_REIN_ALTERNATING BuiltInParameter.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: shapeId should refer to two dimensional Rebar Shape element with segments forming only right angles.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions DisabledDisciplineException When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InvalidOperationException When setting this property: This Path Reinforcement does not have alternating bars enabled. -or- When setting this property: This PathReinforcement does not host Rebar.

See Also