Current Property


Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public virtual MacroModule Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As MacroModule
	Get
Visual C++
public:
virtual property MacroModule^ Current {
	MacroModule^ get ();
}

Implements

IEnumerator T Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException There is no current item in the iterator.

See Also