Computes the geometric representation of the instance.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
An element which contains the computed geometry for the instance.Remarks
The geometry will be in the coordinate system of the model that owns this instance.
The context of the instance object (such as effective material) will be applied to the symbol.
Note that this method involves extensive parsing or Revit's data structures, so try to
minimize calls if performance is critical.
Geometry will be parsed with the same options as those used when this object was retrieved.
This method returns a copy of the Revit geometry. It is suitable for use in a tool which extracts
geometry to another format or carries out a geometric analysis; however, because it returns a copy
the references found in the geometry objects contained in this element are not suitable for
creating new Revit elements referencing the original element (for example, dimensioning).
Only the geometry returned by GetSymbolGeometry() with no transform can be used for that purpose.