CanCalculateGeometry Method


This indicates whether the input spatial element is a valid one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public static bool CanCalculateGeometry(
	SpatialElement spatialElement
)
Visual Basic
Public Shared Function CanCalculateGeometry ( _
	spatialElement As SpatialElement _
) As Boolean
Visual C++
public:
static bool CanCalculateGeometry(
	SpatialElement^ spatialElement
)

Parameters

spatialElement
Type: Autodesk.Revit.DB SpatialElement
The spatial element to be checked if its geometry can be calculated.

Return Value

It will return false if the room/space is not enclosed in 2d or has no location, or the height is too small.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also