GUID Property


Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public virtual Guid GUID { get; }
Visual Basic
Public Overridable ReadOnly Property GUID As Guid
	Get
Visual C++
public:
virtual property Guid GUID {
	Guid get ();
}

Remarks

Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.

See Also