The location of the connector.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Implements
IConnector OriginRemarks
Changing the location of the connector may lead to changes of location
and geometry for the connector's host element and the hosts for other elements
the element is connected to.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when connector's type is NonEndConn. Thrown when the connector is a part of a family instance. |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the assigned origin is invalid. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown on failure to set origin. |