MassGBXMLExportOptions Constructor (IList(ElementId))


Constructs a new instance of the options used to export a mass model to gbXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public MassGBXMLExportOptions(
	IList<ElementId> massZoneIds
)
Visual Basic
Public Sub New ( _
	massZoneIds As IList(Of ElementId) _
)
Visual C++
public:
MassGBXMLExportOptions(
	IList<ElementId^>^ massZoneIds
)

Parameters

massZoneIds
Type: System.Collections.Generic IList ElementId
Indicates the mass zones to analyze in the exported gbXML.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also