A filter used to match rooms.
Namespace:
Autodesk.Revit.DB.Architecture
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements
before the elements are obtained and expanded. Therefore this filter does not have to be
paired with another quick filter to minimize the number of Elements that are expanded.
Examples
Copy
C#
// Use a RoomFilter to find all room elements in the document. It is necessary to use the RoomFilter,
// and not an ElementClassFilter or the shortcut method OfClass() because the Room class is not
// supported by those methods.
RoomFilter filter = new RoomFilter();
// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();
Copy
VB.NET
' Use a RoomFilter to find all room elements in the document. It is necessary to use the RoomFilter,
' and not an ElementClassFilter or the shortcut method OfClass() because the Room class is not
' supported by those methods.
Dim filter As New RoomFilter()
' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim rooms As IList(Of Element) = collector.WherePasses(filter).ToElements()
Inheritance Hierarchy
System
Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB.Architecture RoomFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB.Architecture RoomFilter