IsValidOpeningForHide Method


Returns true if opening with given Identifier could be hidden, false for all other Identifiers.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidOpeningForHide(
	ElementId openingId
)
Visual Basic
Public Function IsValidOpeningForHide ( _
	openingId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidOpeningForHide(
	ElementId^ openingId
)

Parameters

openingId
Type: Autodesk.Revit.DB ElementId
Identifier of opening to check.

Return Value

True for openings which are valid to be hidden, false for all other Identifiers.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also